poj 3468 A Simple Problem with Integers

March 4, 2013
POJ

A Simple Problem with Integers Time Limit: 5000MS Memory Limit: 131072K Total Submissions:40260 Accepted: 11693 Case Time Limit: 2000MS

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000. The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000. Each of the next Q lines represents an operation. “C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000. “Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4

Sample Output

4 55 9 15

Hint The sums may exceed the range of 32-bit integers.

#include <cstdio>
#include <algorithm>
using namespace std;
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
#define LL long long int
const int maxn = 111111;
LL col[maxn<<2], sum[maxn<<2];
void PushUP(int rt){
  sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void PushDown(int rt, int m){
  if (col[rt]){
    col[rt<<1] += col[rt]; col[rt<<1|1] += col[rt];
    sum[rt<<1] += (LL)(col[rt] *(m-(m>>1)));
    sum[rt<<1|1] += (LL)(col[rt] *(m>>1));
    col[rt] = 0;
  }
}
void build(int l, int r, int rt){
  col[rt] = 0; if (l == r) {scanf("%lld", sum + rt); return;}
  int m = (l + r) >> 1; build(lson); build(rson); PushUP(rt);
}
void update(int L, int R, int c, int l, int r, int rt){
  if (L <= l && R >= r) {col[rt] += c; sum[rt] += (LL)(c*(r-l+1)); return;}
  PushDown(rt, r - l + 1);
  int m= (l + r) >> 1; 
  if (L <= m) update(L, R, c, lson); if (R > m) update(L, R, c, rson);
  PushUP(rt);
}
LL query(int L, int R, int l, int r, int rt){
  if (L <= l && R >= r){return sum[rt];}
  PushDown(rt, r - l + 1); int m = (l + r) >> 1; LL ret = 0;
  if (L <= m) ret += query(L, R, lson); if (R > m) ret += query(L, R, rson);
  PushUP(rt);
  return ret;
}
int main(void){
  int n, q;
#ifndef ONLINE_JUDGE
  freopen("poj3468.in", "r", stdin);
#endif
  while (~scanf("%d%d", &n, &q)){
    build(1, n, 1);
    while (q--){
      char a[2]; scanf("%s", a); int m, b, c;
      if (a[0] == 'Q') 
      {scanf("%d%d", &m, &b);printf("%lld\n",query(m, b, 1, n, 1));}
      else {
        scanf("%d%d%d", &m, &b, &c); update(m, b, c, 1, n, 1);
      }
    }
  }
  return 0;
}

更新区间的线段树。敲了好几遍,差不多熟悉了,其实敲多了也就明白了。

comments powered by Disqus