hdu 1712 ACboy needs your help 分组背包
March 29, 2013
Hdu
DP
ACboy needs your help
Time Limit: 1000⁄1000 MS (Java/Others) Memory Limit: 32768⁄32768 K (Java/Others) Total Submission(s): 2403 Accepted Submission(s): 1223
Problem Description ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. N = 0 and M = 0 ends the input.
Output For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input 2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
Sample Output 3 4 6
分组背包,唉,开始写还是卡了。。卡在第三层循环有木有!j表示花费,所以呢,只能从1循环到v,不能超过去了。也就是说,对于每一组中的物品,要首先看一下这个物品的花费是不是比v小,然后再考虑要不要放进去。还是看的别人的代码才明白的。。次嗷……以后再也不敢了。。
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
int a[120][120];
int main(void){
#ifndef ONLINE_JUDGE
freopen("1712.in", "r", stdin);
#endif
int n, m, f[200];
while (~scanf("%d%d", &n, &m)){
memset(f, 0, sizeof(f));
if (m+n==0) break;
for (int i = 1; i <= n; ++i)
for (int j = 1; j <= m; ++j)
scanf("%d", &a[i][j]);
for (int i = 1; i <= n ; ++i){
for (int v = m; v >= 0; --v){
for (int j = 1; j <= v; ++j){
f[v] = max(f[v], f[v-j] + a[i][j]);
}
}
}
printf("%d\n", f[m]);
}
return 0;
}
理解,关键是理解!不能盲目照着人家的板子抄。。。