hdu 1394 Minimum Inversion Number

March 2, 2013
Hdu Data Structure

Minimum Inversion Number

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 5892 Accepted Submission(s): 3587

Problem Description The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence) a2, a3, …, an, a1 (where m = 1) a3, a4, …, an, a1, a2 (where m = 2) … an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output For each case, output the minimum inversion number on a single line.

Sample Input 10 1 3 6 9 0 8 5 7 4 2

Sample Output 16

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
const int maxn = 5555;
int sum[maxn<<2];
void PushUP(int rt){
  sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void build(int l, int r, int rt){
  if (l == r) {sum[rt] = 0; return;}
  int m= (l + r) >> 1; build(lson); build(rson); 
  PushUP(rt);
}
void update(int p, int l, int r, int rt){
  if (l == r) {sum[rt]++; return;}
  int m = (l + r) >> 1;
  if (p <= m) update(p, lson); else update(p, rson);
  PushUP(rt);
}
int query(int L, int R, int l, int r, int rt){
  if (L <= l && R >= r) {return sum[rt];}
  int m = (l + r) >> 1, ret = 0;
  if (L <= m) ret += query(L, R, lson);
  if (R > m) ret += query(L, R, rson);
  return ret;
}
int x[maxn];
int main(void){
#ifndef ONLINE_JUDGE
  freopen("hdu1394.in", "r", stdin);
#endif
  int n;
  while (~scanf("%d", &n)){
    int sum = 0; build(0, n-1, 1);
    for (int i = 0; i < n; ++i){
      scanf("%d", x+i); sum += query(x[i],n-1,0,n-1,1);
      update(x[i], 0, n-1, 1);
    }
    int ret = sum;
    for (int i = 0; i < n; ++i){
      sum += n - 1 - x[i] - x[i];
      ret = min(ret, sum);
    }
    printf("%d\n", ret);
  }
  return 0;
}

学习树状数组做的题目,还是想了一下午,自己模拟一下就知道怎么回事了,其实也不难。至于怎么建树,怎么更新树状数组,自己画一个树状的图就可以理解了。就是先用线段树求出原有序列的逆序数,然后再求出其他排列的逆序数,这里有一个技巧,就是45行到48行的代码,自己体会一下就Ok了,很巧妙的。

comments powered by Disqus