hdu 1212 Big Number
March 12, 2013
Hdu
Big Number
Time Limit: 2000⁄1000 MS (Java/Others) Memory Limit: 65536⁄32768 K (Java/Others) Total Submission(s): 3386 Accepted Submission(s): 2305
Problem Description As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
Input The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
Output For each test case, you have to ouput the result of A mod B.
Sample Input 2 3 12 7 152455856554521 3250
Sample Output 2 5 1521
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
using namespace std;
char a[1000+10]; int b;
int main(void){
#ifndef ONLINE_JUDGE
freopen("1212.in", "r", stdin);
#endif
while (~scanf("%s%d", a, &b)){
int len = strlen(a); int x = a[len-1]-'0', po = 1;
x = x % b; int y;
for (int i = len - 2; i >= 0; --i){
y = a[i] - '0'; po = (po * 10) % b;
x = (x + y*po) % b;
}
printf("%d\n", x);
}
return 0;
}
看了讨论版学会的,不过还是有一点儿小问题,学一下数论吧……