hdu 1196

January 22, 2013
Hdu

Lowest Bit

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 5440 Accepted Submission(s): 3963

Problem Description Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.

Output For each A in the input, output a line containing only its lowest bit.

Sample Input 26 88 0

Sample Output 2 8

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>

using namespace std;

int main(void)
{
    int n;
#ifndef ONLINE_JUDGE
    freopen("1196.in", "r", stdin);
#endif
    while (~scanf("%d", &n) && n)
    {
        printf("%d\n", ((~n+1)&n));
    }

    return 0;
}

超级简单的一道题目……

comments powered by Disqus