hdu 1161 Eddy's mistakes

November 23, 2012
Hdu

Eddy’s mistakes

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 5189 Accepted Submission(s): 2956

Problem Description Eddy usually writes articles ,but he likes mixing the English letter uses, for example “computer science” is written frequently “coMpUtEr scIeNce” by him, this mistakes lets Eddy’s English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.

Input The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation composition, the writing length does not surpass 1000 characters.

Output For each test case, you should output an only line, after namely the result of transforms the lowercase letter.

Sample Input weLcOmE tO HDOj Acm 2005!

Sample Output welcome to hdoj acm 2005!

#include <iostream>
#include <cctype>
#include <cstdlib>
#include <cstdio>
using namespace std;
int main(void)
{
    char a[1000+10];

    while (gets(a)!=NULL)
    {
        for (int i = 0; a[i] != '\0'; ++i)if(isalpha(a[i]))a[i]=tolower(a[i]);
        cout << a << endl;
    }
    return 0;
}

水题。

comments powered by Disqus