hdu 1108 最小公倍数

March 12, 2013
Hdu

最小公倍数

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 24145 Accepted Submission(s): 13180

Problem Description 给定两个正整数,计算这两个数的最小公倍数。

Input 输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.

Output 对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。

Sample Input 10 14

Sample Output 70

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
int gcd(int a, int b){
  return b == 0 ? a : gcd(b, a%b);
}
int main(void){
  int a, b;
#ifndef ONLINE_JUDGE
  freopen("1108.in", "r", stdin);
#endif
  while (~scanf("%d%d", &a, &b)){
    printf("%d\n", a * b / gcd(a, b));
  }
  return 0;
}

基础的数学题……

comments powered by Disqus