hdu 1076
January 22, 2013
Hdu
An Easy Task
Time Limit: 2000⁄1000 MS (Java/Others) Memory Limit: 65536⁄32768 K (Java/Others) Total Submission(s): 10133 Accepted Submission(s): 6291
Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains two positive integers Y and N(1<=N<=10000).
Output For each test case, you should output the Nth leap year from year Y.
Sample Input 3 2005 25 1855 12 2004 10000
Sample Output 2108 1904 43236
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
bool leap(int n)
{
if (n%400 == 0 || (n%4==0 && n%100!=0))
return true;
else return false;
}
int main(void)
{
int t;
#ifndef ONLINE_JUDGE
freopen("1076.in", "r", stdin);
#endif
scanf("%d", &t);
while (t--)
{
int n, y;
scanf("%d%d", &y, &n);
if (leap(y))
{
int cnt = 1, end;
for (int i = y+4; ; ++i)
{
if (leap(i))
cnt++;
if (cnt == n)
{
end = i;
break;
}
}
printf("%d\n", end);
}
else
{
int cnt = 0, end;
for (int i = y; ; ++i)
{
if (leap(i))
cnt++;
if (cnt == n)
{
end = i;
break;
}
}
printf("%d\n", end);
}
}
return 0;
}
这题不难……