hdu 1061 Rightmost Digit

March 13, 2013
Hdu

Rightmost Digit

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 22887 Accepted Submission(s): 8739

Problem Description Given a positive integer N, you should output the most right digit of N^N.

Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output For each test case, you should output the rightmost digit of N^N.

Sample Input 2 3 4

Sample Output 7 6 Hint In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
using namespace std;
int main(void){
#ifndef ONLINE_JUDGE
  freopen("1061.in", "r", stdin);
#endif
  int t; long long n; 
  while (~scanf("%d", &t))
  while (t--){
    scanf("%lld", &n);
    int m = n % 10, l = n % 4 + 4, s = m; 
    for (int i = 1; i < l; ++i) s *= m;
    printf("%d\n", s%10);
  }
  return 0;
}

这道题目还是很困惑,为什么说多test cases 还要加 while (~scanf(“%d”, &t)) 这句话?难道是每一个test case 又有多个cases?

因为这个原因卡了很久……次嗷……

comments powered by Disqus