hdu 1049

January 22, 2013
Hdu

Climbing Worm

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 8745 Accepted Submission(s): 5659

Problem Description An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input 10 2 1 20 3 1 0 0 0

Sample Output 17 19

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>

using namespace std;

int main(void)
{
#ifndef ONLINE_JUDGE
    freopen("1049.in", "r", stdin);
#endif
    int n, u, d, sum; 
    while (scanf("%d%d%d", &n, &u, &d), n)
    {
        sum = 0;
        int len = 0;
        while (len < n)
        {
            sum += 1;
            len += u;
            if (len >= n)
                break;
            len -= d;
            sum += 1;
        }
        printf("%d\n", sum);
    }

    return 0;
}

不难……理解就好

comments powered by Disqus