hdu 1019 Least Common Multiple

March 13, 2013
Hdu

Least Common Multiple

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 21158 Accepted Submission(s): 7899

Problem Description The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input 2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output 105 10296

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
using namespace std;
int gcd(int a, int b){
  return b == 0 ? a : gcd(b, a%b);
}
int main(void){
  int t; 
#ifndef ONLINE_JUDGE
  freopen("1019.in", "r", stdin);
#endif
  scanf("%d", &t);{
    while (t--){
      int n; scanf("%d", &n);
      int a, b, c; n--; scanf("%d", &a);
      while (n--){
        scanf("%d", &b);
        a = b / gcd(a, b) * a;
      }
      printf("%d\n", a);
    }
  }
  return 0;
}

这题和又和原来的不一样了……纠结,输入t的时候,不能用 while (~scanf(“%d”,&t)) ……唉,蛋疼……

又测试了一下,原来可以按照上面的用,发现如果改成long long int 就WA,为毛?……

comments powered by Disqus