hdu 1018 Big Number

March 13, 2013
Hdu

Big Number

Time Limit: 20001000 MS (Java/Others) Memory Limit: 6553632768 K (Java/Others) Total Submission(s): 18525 Accepted Submission(s): 8292

Problem Description In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input 2 10 20

Sample Output 7 19

#include <cstdio>
#include <cstdlib>
#include <cmath>
using namespace std;
int main(void){
  int t; 
#ifndef ONLINE_JUDGE
  freopen("1018.in", "r", stdin);
#endif
  while (~scanf("%d", &t)){
    while(t--){
      int n; double sum = 0; int temp; scanf("%d", &n);
      for (int i = 1; i < n + 1; ++i) sum += log10(i);
      temp = ceil(sum);
      printf("%d\n", temp);
    }
  }
  return 0;
}

看的讨论板……看来数学类的水题也是需要技巧的。

comments powered by Disqus